[Tfug] no cpu scaling lately on a core2 duo

JD Rogers rogersjd at gmail.com
Fri Jan 27 14:44:03 MST 2012

For I-don't-know-how-long my ubuntu laptop has seemed sluggish. I have
been blaming the unity/compiz interface and dabbled some with
2D-unity, gnome shell, kde, and xfce, but it didn't make a huge
difference. I've been really annoyed that all the WM's and desktop
environments have gotten so bloated that things are so much slower. I
never would have guessed my CPU has been locked at half speed all this

Today I finally noticed that my core2 duo T60 (don't laugh, I'm still
mostly productive on it) has been permanently stuck at 1.0GHz. I'm
embarrassed that I didn't notice this earlier, but the ondemand
governor never let me down before, and sadly I don't have as much time
to tinker and tune as I did years ago. I know scaling used to work
flawlessly, because I used to pay much more attention to this when I
was running simulations on this laptop in years past but still cared
about battery life. I've never reinstalled, only upgraded ubuntu since

Anyone have any ideas where to even look to track this down? So far:

Tried booting an older 2.6 kernel, same results as the up-to-date
3.0.0-15-generic kernel on Ubuntu 11.10

"cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor" returns
ondemand for both cores.

"cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_available_frequencies"
returns 2000000 1667000 1333000 1000000

"watch -n.1 cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_cur_freq"
returns a steady 1000000 1000000 even when I run a simulation that
puts both cores at 100% according to top.

However, I know for sure the cores are _capable_ of scaling because
while the above watch command is running, I happen to notice that
plugging or unplugging the power cord returns a brief bounce or two up
to 2000000 or sometimes one of the intermediate freqs.

Any thoughts on how to further track this one down will be appreciated.


More information about the tfug mailing list